请选择 进入手机版 | 继续访问电脑版

顶牛论坛

 找回密码
 立即注册
搜索

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

量价招式擒获飞天妖股

强势黑马起爆点指标主力吸筹完毕启动四色柱很牛的副图指标黄金柱  好用的成交量指标
机构买入看盘牛股启动指标公式百万股神擒牛指标公式短线底部抄底和高位逃顶指标
绝密量能买点主力暴力拉升指标公式洞察主力游资大户散户资金王子操盘线指标公式
集合竞价抓板指标公式通达信龙虎榜通达信主力控盘系数通达信六区DK指标
抓起爆点超精准选股公式通达信控盘程度选股公式源码RSI突破下降趋势线股票活跃度指标公式
查看: 2426|回复: 4

[通达信] 通达信龙虎榜(源码 副图 主图 贴图)

[复制链接]

9458

主题

13

听众

6万

积分

顶牛元老

Rank: 8Rank: 8

UID
507
好友
8
精华
1
顶牛币
23377
在线时间
509 小时
注册时间
2012-10-24
发表于 2017-12-13 08:37 |显示全部楼层
分享到:

通达信指标公式


一、主图
{均线系统}
M5:MA(CLOSE,5);
M10:MA(CLOSE,10);
M20:MA(CLOSE,20);
M60:MA(CLOSE,60);
M120:MA(CLOSE,120);
M200:MA(CLOSE,200);
STICKLINE(CLOSE/REF(C,1)>=1.097,O,C,1,0),COLORYELLOW;
{龙虎榜}
LHB:=SIGNALS_USER(490,0)-SIGNALS_USER(491,0);  {龙虎榜净买入额}
DRAWTEXT(LHB>0 AND LHB<10000,L*0.95,VARCAT(VARCAT('▲龙虎: ',VAR2STR(LHB,0)),'万')),COLORMAGENTA;
DRAWTEXT(LHB>10000,L*0.95,VARCAT(VARCAT('▲龙虎: ',VAR2STR(LHB/10000,2)),'亿')),COLORMAGENTA;
DRAWTEXT(LHB<0 AND LHB>-10000,L*0.95,VARCAT(VARCAT('▲龙虎: ',VAR2STR(LHB,0)),'万')),COLORGREEN;
DRAWTEXT(LHB<-10000,L*0.95,VARCAT(VARCAT('▲龙虎: ',VAR2STR(LHB/10000,2)),'亿')),COLORGREEN;
二、副图
uu:0 1  0.97
总买:=SIGNALS_USER(490,0);
总卖:=-ABS(SIGNALS_USER(491,0));
STICKLINE(总买>0,0,总买,0.5,0),COLORRED;
STICKLINE(总卖<0,0,总卖,0.5,0),COLORGREEN;
DRAWTEXT(总买>0 AND 总买<10000,总买/1.05,VARCAT(VARCAT('总买:',VAR2STR(总买,2)),'万'));
DRAWTEXT(总买>10000,总买/1.05,VARCAT(VARCAT('总买:',VAR2STR(总买/10000,2)),'亿'));
DRAWTEXT(总卖<0 AND 总卖>-10000,总卖/1.05,VARCAT(VARCAT('总卖:',VAR2STR(总卖,2)),'万'));
DRAWTEXT(总卖<-10000,总卖/1.05,VARCAT(VARCAT('总卖:',VAR2STR(总卖/10000,2)),'亿'));
上海金碧路_买:=SIGNALS_USER(1,0),NODRAW;

上海金碧路_卖:=-ABS(SIGNALS_USER(2,0)),NODRAW;
金碧路:SIGNALS_USER(1,0)-SIGNALS_USER(2,0),NODRAW;
STICKLINE(上海金碧路_买>0,0,上海金碧路_买,0.5,0),COLORFF0080;
STICKLINE(上海金碧路_卖<0,0,上海金碧路_卖,0.5,0),COLORFF0080;
深圳益田路_买:=SIGNALS_USER(3,0),NODRAW;
深圳益田路_卖:=-ABS(SIGNALS_USER(4,0)),NODRAW;
益田路:SIGNALS_USER(3,0)-SIGNALS_USER(4,0),NODRAW;
STICKLINE(深圳益田路_买>0,0,深圳益田路_买,0.5,0),COLORFF80FF;
STICKLINE(深圳益田路_卖<0,0,深圳益田路_卖,0.5,0),COLORFF80FF;
临安万马路_买:=SIGNALS_USER(5,0),NODRAW;
临安万马路_卖:=-ABS(SIGNALS_USER(6,0)),NODRAW;
万马路:SIGNALS_USER(5,0)-SIGNALS_USER(6,0),NODRAW;
STICKLINE(临安万马路_买>0,0,临安万马路_买,0.5,0),COLORDB518B;
STICKLINE(临安万马路_卖<0,0,临安万马路_卖,0.5,0),COLORDB518B;
无锡清扬路_买:=SIGNALS_USER(7,0),NODRAW;
无锡清扬路_卖:=-ABS(SIGNALS_USER(8,0)),NODRAW;
清扬路:SIGNALS_USER(7,0)-SIGNALS_USER(8,0),NODRAW;
STICKLINE(无锡清扬路_买>0,0,无锡清扬路_买,0.5,0),COLORFF0080;
STICKLINE(无锡清扬路_卖<0,0,无锡清扬路_卖,0.5,0),COLORFF0080;
成都南一环路_买:=SIGNALS_USER(9,0),NODRAW;
成都南一环路_卖:=-ABS(SIGNALS_USER(10,0)),NODRAW;
南一环路:SIGNALS_USER(9,0)-SIGNALS_USER(10,0),NODRAW;
STICKLINE(成都南一环路_买>0,0,成都南一环路_买,0.5,0),COLORFF8000;
STICKLINE(成都南一环路_卖<0,0,成都南一环路_卖,0.5,0),COLORFF8000;
上海淮海中路_买:=SIGNALS_USER(11,0),NODRAW;
上海淮海中路_卖:=-ABS(SIGNALS_USER(12,0)),NODRAW;
上海淮海中路:SIGNALS_USER(11,0)-SIGNALS_USER(12,0),NODRAW;
STICKLINE(上海淮海中路_买>0,0,上海淮海中路_买,0.5,0),COLORFF8000;
STICKLINE(上海淮海中路_卖<0,0,上海淮海中路_卖,0.5,0),COLORFF8000;
成都北一环_买:=SIGNALS_USER(13,0),NODRAW;
成都北一环_卖:=-ABS(SIGNALS_USER(14,0)),NODRAW;
成都北一环:SIGNALS_USER(13,0)-SIGNALS_USER(14,0),NODRAW;
STICKLINE(成都北一环_买>0,0,成都北一环_买,0.5,0), COLOR1471CD;
STICKLINE(成都北一环_卖<0,0,成都北一环_卖,0.5,0), COLOR1471CD;
上海保定路_买:=SIGNALS_USER(15,0),NODRAW;
上海保定路_卖:=-ABS(SIGNALS_USER(16,0)),NODRAW;
上海保定路:SIGNALS_USER(15,0)+SIGNALS_USER(16,0),NODRAW;
STICKLINE(上海保定路_买>0,0,上海保定路_买,0.5,0),COLORFFFF80;
STICKLINE(上海保定路_卖<0,0,上海保定路_卖,0.5,0),COLORFFFF80;
厦门厦禾路_买:=SIGNALS_USER(17,0),NODRAW;
厦门厦禾路_卖:=-ABS(SIGNALS_USER(18,0)),NODRAW;
厦禾路:SIGNALS_USER(17,0)-SIGNALS_USER(18,0),NODRAW;
STICKLINE(厦门厦禾路_买>0,0,厦门厦禾路_买,0.5,0), COLOR800080;
STICKLINE(厦门厦禾路_卖<0,0,厦门厦禾路_卖,0.5,0), COLOR800080;
上海互联网路_买:=SIGNALS_USER(19,0),NODRAW;
上海互联网路_卖:=-ABS(SIGNALS_USER(20,0)),NODRAW;
上海互联网路:SIGNALS_USER(19,0)-SIGNALS_USER(20,0),NODRAW;
STICKLINE(上海互联网路_买>0,0,上海互联网路_买,0.5,0),COLOR8080FF;
STICKLINE(上海互联网路_卖<0,0,上海互联网路_卖,0.5,0),COLOR8080FF;
上海武定路_买:=SIGNALS_USER(21,0),NODRAW;
上海武定路_卖:=-ABS(SIGNALS_USER(22,0)),NODRAW;
武定路:SIGNALS_USER(21,0)-SIGNALS_USER(22,0),NODRAW;
STICKLINE(上海武定路_买>0,0,上海武定路_买,0.5,0),COLOR0080FF;
STICKLINE(上海武定路_卖<0,0,上海武定路_卖,0.5,0),COLOR0080FF;
上海古北路_买:=SIGNALS_USER(23,0),NODRAW;
上海古北路_卖:=-ABS(SIGNALS_USER(24,0)),NODRAW;
古北路:SIGNALS_USER(23,0)-SIGNALS_USER(24,0),NODRAW;
STICKLINE(上海古北路_买>0,0,上海古北路_买,0.5,0),COLOR8000FF;
STICKLINE(上海古北路_卖<0,0,上海古北路_卖,0.5,0),COLOR8000FF;
机构专用_买:=SIGNALS_USER(498,0),NODRAW;
机构专用_卖:=-ABS(SIGNALS_USER(499,0)),NODRAW;
机构专用:SIGNALS_USER(498,0)-SIGNALS_USER(499,0),NODRAW;
STICKLINE(机构专用_买>0,0,机构专用_买,0.5,0),COLOR00FFFF;
STICKLINE(机构专用_卖<0,0,机构专用_卖,0.5,0),COLOR00FFFF;
AB:=IF(总买!=DRAWNULL,1,UU),NODRAW;
DRAWTEXT(临安万马路_买>0 AND 临安万马路_买<10000,临安万马路_买*AB,VARCAT(VARCAT('—临安万马路:',VAR2STR(临安万马路_买,2)),'万')),COLORYELLOW;
DRAWTEXT(临安万马路_买>10000,临安万马路_买*AB,VARCAT(VARCAT('—临安万马路:',VAR2STR(临安万马路_买/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(临安万马路_卖<0 AND 临安万马路_卖>-10000,临安万马路_卖*AB,VARCAT(VARCAT('—临安万马路:',VAR2STR(临安万马路_卖,2)),'万')),COLORYELLOW;
DRAWTEXT(临安万马路_卖<-10000,临安万马路_卖*AB,VARCAT(VARCAT('—临安万马路:',VAR2STR(临安万马路_卖/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(深圳益田路_买>0 AND 深圳益田路_买<10000,深圳益田路_买*AB,VARCAT(VARCAT('—深圳益田路:',VAR2STR(深圳益田路_买,2)),'万')),COLORYELLOW;

傲游截图20171212170429.png

9458

主题

13

听众

6万

积分

顶牛元老

Rank: 8Rank: 8

UID
507
好友
8
精华
1
顶牛币
23377
在线时间
509 小时
注册时间
2012-10-24
发表于 2017-12-13 08:38 |显示全部楼层

DRAWTEXT(深圳益田路_买>10000,深圳益田路_买*AB,VARCAT(VARCAT('—深圳益田路:',VAR2STR(深圳益田路_买/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(深圳益田路_卖<0 AND 深圳益田路_卖>-10000,深圳益田路_卖*AB,VARCAT(VARCAT('—深圳益田路:',VAR2STR(深圳益田路_卖,2)),'万')),COLORYELLOW;
DRAWTEXT(深圳益田路_卖<-10000,深圳益田路_卖*AB,VARCAT(VARCAT('—深圳益田路:',VAR2STR(深圳益田路_卖/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(机构专用_买>0 AND 机构专用_买<10000,机构专用_买*AB,VARCAT(VARCAT('—机构专用:',VAR2STR(机构专用_买,2)),'万')),COLORYELLOW;
DRAWTEXT(机构专用_买>10000,机构专用_买*AB,VARCAT(VARCAT('—机构专用:',VAR2STR(机构专用_买/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(机构专用_卖<0 AND 机构专用_卖>-10000,机构专用_卖*AB,VARCAT(VARCAT('—机构专用:',VAR2STR(机构专用_卖,2)),'万')),COLORYELLOW;
DRAWTEXT(机构专用_卖<-10000,机构专用_卖*AB,VARCAT(VARCAT('—机构专用:',VAR2STR(机构专用_卖/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(成都南一环路_买>0 AND 成都南一环路_买<10000,成都南一环路_买*AB,VARCAT(VARCAT('—成都南一环路:',VAR2STR(成都南一环路_买,2)),'万')),COLORYELLOW;
DRAWTEXT(成都南一环路_买>10000,成都南一环路_买*AB,VARCAT(VARCAT('—成都南一环路:',VAR2STR(成都南一环路_买/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(成都南一环路_卖<0 AND 成都南一环路_卖>-10000,成都南一环路_卖*AB,VARCAT(VARCAT('—成都南一环路:',VAR2STR(成都南一环路_卖,2)),'万')),COLORYELLOW;
DRAWTEXT(成都南一环路_卖<-10000,成都南一环路_卖*AB,VARCAT(VARCAT('—成都南一环路:',VAR2STR(成都南一环路_卖/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(成都北一环_买>0 AND 成都北一环_买<10000,成都北一环_买*AB,VARCAT(VARCAT('—成都北一环:',VAR2STR(成都北一环_买,2)),'万')),COLORYELLOW;
DRAWTEXT(成都北一环_买>10000,成都北一环_买*AB,VARCAT(VARCAT('—成都北一环:',VAR2STR(成都北一环_买/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(成都北一环_卖<0 AND 成都北一环_卖>-10000,成都北一环_卖*AB,VARCAT(VARCAT('—成都北一环:',VAR2STR(成都北一环_卖,2)),'万')),COLORYELLOW;
DRAWTEXT(成都北一环_卖<-10000,成都北一环_卖*AB,VARCAT(VARCAT('—成都北一环:',VAR2STR(成都北一环_卖/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(上海淮海中路_买>0 AND 上海淮海中路_买<10000,上海淮海中路_买*AB,VARCAT(VARCAT('—上海淮海中路:',VAR2STR(上海淮海中路_买,2)),'万')),COLORYELLOW;
DRAWTEXT(上海淮海中路_买>10000,上海淮海中路_买*AB,VARCAT(VARCAT('—上海淮海中路:',VAR2STR(上海淮海中路_买/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(上海淮海中路_卖<0 AND 上海淮海中路_卖>-10000,上海淮海中路_卖*AB,VARCAT(VARCAT('—上海淮海中路:',VAR2STR(上海淮海中路_卖,2)),'万')),COLORYELLOW;
DRAWTEXT(上海淮海中路_卖<-10000,上海淮海中路_卖*AB,VARCAT(VARCAT('—上海淮海中路:',VAR2STR(上海淮海中路_卖/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(上海互联网路_买>0 AND 上海互联网路_买<10000,上海互联网路_买*AB,VARCAT(VARCAT('—上海互联网路:',VAR2STR(上海互联网路_买,2)),'万')),COLORYELLOW;
DRAWTEXT(上海互联网路_买>10000,上海互联网路_买*AB,VARCAT(VARCAT('—上海互联网路:',VAR2STR(上海互联网路_买/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(上海互联网路_卖<0 AND 上海互联网路_卖>-10000,上海互联网路_卖*AB,VARCAT(VARCAT('—上海互联网路:',VAR2STR(上海互联网路_卖,2)),'万')),COLORYELLOW;
DRAWTEXT(上海互联网路_卖<-10000,上海互联网路_卖*AB,VARCAT(VARCAT('—上海互联网路:',VAR2STR(上海互联网路_卖/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(上海保定路_买>0 AND 上海保定路_买<10000,上海保定路_买*AB,VARCAT(VARCAT('—上海保定路:',VAR2STR(上海保定路_买,2)),'万')),COLORYELLOW;
DRAWTEXT(上海保定路_买>10000,上海保定路_买*AB,VARCAT(VARCAT('—上海保定路:',VAR2STR(上海保定路_买/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(上海保定路_卖<0 AND 上海保定路_卖>-10000,上海保定路_卖*AB,VARCAT(VARCAT('—上海保定路:',VAR2STR(上海保定路_卖,2)),'万')),COLORYELLOW;
DRAWTEXT(上海保定路_卖<-10000,上海保定路_卖*AB,VARCAT(VARCAT('—上海保定路:',VAR2STR(上海保定路_卖/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(厦门厦禾路_买>0 AND 厦门厦禾路_买<10000,厦门厦禾路_买*AB,VARCAT(VARCAT('—厦门厦禾路:',VAR2STR(厦门厦禾路_买,2)),'万')),COLORYELLOW;
DRAWTEXT(厦门厦禾路_买>10000,厦门厦禾路_买*AB,VARCAT(VARCAT('—厦门厦禾路:',VAR2STR(厦门厦禾路_买/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(厦门厦禾路_卖<0 AND 厦门厦禾路_卖>-10000,厦门厦禾路_卖*AB,VARCAT(VARCAT('—厦门厦禾路:',VAR2STR(厦门厦禾路_卖,2)),'万')),COLORYELLOW;
DRAWTEXT(厦门厦禾路_卖<-10000,厦门厦禾路_卖*AB,VARCAT(VARCAT('—厦门厦禾路:',VAR2STR(厦门厦禾路_卖/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(上海武定路_买>0 AND 上海武定路_买<10000,上海武定路_买*AB,VARCAT(VARCAT('—上海武定路:',VAR2STR(上海武定路_买,2)),'万')),COLORYELLOW;
DRAWTEXT(上海武定路_买>10000,上海武定路_买*AB,VARCAT(VARCAT('—上海武定路:',VAR2STR(上海武定路_买/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(上海武定路_卖<0 AND 上海武定路_卖>-10000,上海武定路_卖*AB,VARCAT(VARCAT('—上海武定路:',VAR2STR(上海武定路_卖,2)),'万')),COLORYELLOW;
DRAWTEXT(上海武定路_卖<-10000,上海武定路_卖*AB,VARCAT(VARCAT('—上海武定路:',VAR2STR(上海武定路_卖/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(上海金碧路_买>0 AND 上海金碧路_买<10000,上海金碧路_买*AB,VARCAT(VARCAT('—上海金碧路:',VAR2STR(上海金碧路_买,2)),'万')),COLORYELLOW;
DRAWTEXT(上海金碧路_买>10000,上海金碧路_买*AB,VARCAT(VARCAT('—上海金碧路:',VAR2STR(上海金碧路_买/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(上海金碧路_卖<0 AND 上海金碧路_卖>-10000,上海金碧路_卖*AB,VARCAT(VARCAT('—上海金碧路:',VAR2STR(上海金碧路_卖,2)),'万')),COLORYELLOW;
DRAWTEXT(上海金碧路_卖<-10000,上海金碧路_卖*AB,VARCAT(VARCAT('—上海金碧路:',VAR2STR(上海金碧路_卖/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(无锡清扬路_买>0 AND 无锡清扬路_买<10000,无锡清扬路_买*AB,VARCAT(VARCAT('—无锡清扬路:',VAR2STR(无锡清扬路_买,2)),'万')),COLORYELLOW;
DRAWTEXT(无锡清扬路_买>10000,无锡清扬路_买*AB,VARCAT(VARCAT('—无锡清扬路:',VAR2STR(无锡清扬路_买/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(无锡清扬路_卖<0 AND 无锡清扬路_卖>-10000,无锡清扬路_卖*AB,VARCAT(VARCAT('—无锡清扬路:',VAR2STR(无锡清扬路_卖,2)),'万')),COLORYELLOW;
DRAWTEXT(无锡清扬路_卖<-10000,无锡清扬路_卖*AB,VARCAT(VARCAT('—无锡清扬路:',VAR2STR(无锡清扬路_卖/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(上海古北路_买>0 AND 上海古北路_买<10000,上海古北路_买*AB,VARCAT(VARCAT('—上海古北路:',VAR2STR(上海古北路_买,2)),'万')),COLORYELLOW;
DRAWTEXT(上海古北路_买>10000,上海古北路_买*AB,VARCAT(VARCAT('—上海古北路:',VAR2STR(上海古北路_买/10000,2)),'亿')),COLORYELLOW;
DRAWTEXT(上海古北路_卖<0 AND 上海古北路_卖>-10000,上海古北路_卖*AB,VARCAT(VARCAT('—上海古北路:',VAR2STR(上海古北路_卖,2)),'万')),COLORYELLOW;
DRAWTEXT(上海古北路_卖<-10000,上海古北路_卖*AB,VARCAT(VARCAT('—上海古北路:',VAR2STR(上海古北路_卖/10000,2)),'亿')),COLORYELLOW;
三、选股
第N天前上榜  0   500   1
龙虎榜:=SIGNALS_USER(490,0) OR SIGNALS_USER(491,0);
选出上榜的个股:REF(龙虎榜,第N天前上榜-1) AND V!=0;
回复

使用道具 举报

0

主题

2

听众

2万

积分

顶牛元老

Rank: 8Rank: 8

UID
90591
好友
5
精华
0
顶牛币
7129
在线时间
77 小时
注册时间
2018-1-17
发表于 2018-2-25 07:00 |显示全部楼层
回复

使用道具 举报

0

主题

2

听众

1万

积分

顶牛元老

Rank: 8Rank: 8

UID
71836
好友
0
精华
0
顶牛币
11572
在线时间
15 小时
注册时间
2014-11-7
发表于 2019-4-15 02:21 |显示全部楼层
回复

使用道具 举报

0

主题

1

听众

887

积分

顶牛庄家

Rank: 4

UID
93561
好友
1
精华
0
顶牛币
294
在线时间
28 小时
注册时间
2019-5-19
发表于 2019-5-19 17:51 |显示全部楼层
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册


回顶部