请选择 进入手机版 | 继续访问电脑版

顶牛论坛

 找回密码
 立即注册
搜索

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

量价招式擒获飞天妖股

强势黑马起爆点指标主力吸筹完毕启动四色柱很牛的副图指标黄金柱  好用的成交量指标
机构买入看盘牛股启动指标公式百万股神擒牛指标公式短线底部抄底和高位逃顶指标
绝密量能买点主力暴力拉升指标公式洞察主力游资大户散户资金王子操盘线指标公式
集合竞价抓板指标公式通达信龙虎榜通达信主力控盘系数通达信六区DK指标
抓起爆点超精准选股公式通达信控盘程度选股公式源码RSI突破下降趋势线股票活跃度指标公式
查看: 66003|回复: 469

[通达信] 【公式改写成选股公式】 老帖新开

  [复制链接]

23

主题

10

听众

5万

积分

版主

Rank: 7Rank: 7Rank: 7

UID
26
好友
16
精华
6
顶牛币
25550
在线时间
143 小时
注册时间
2012-9-4
发表于 2012-9-30 23:50 |显示全部楼层
分享到:
本帖最后由 晓羽 于 2012-10-1 00:07 编辑

    适逢双节之际指标区老帖新开,套牢.初学者.晓羽在此恭祝新老牛友及家人中秋国庆双节幸福快乐!吉祥如意!衷心祝愿新顶牛越办越火!!!!  
  
  关于改些公式的几点说明:

1.本帖专为既有公式改写成选股公式而设,其余问题请勿贴在此帖内。
2.后来的发帖者,请先查看下前面各楼的情况,您欲问的问题是否已有人问过,免得重复提问
2.公式需为源码,并请尽量注明完整(含公式名称,参数,适用软件通达信大智慧)
4.请清楚点出要选股的条件,选股周期,如能贴图说明更好。
5.改写选股公式将由套牢版主,初学者版主和我共同为大家一起服务。有不足之处还请大家及时指正!!
已有 4 人评分积分 顶牛币 收起 理由
英雄联盟 + 1 内幕股QQ2289439322
山之旁 + 200 + 200 顶牛论坛有你更精彩
股民糖糖 + 20 + 20 很给力!我在自己的博客上给加了链接了。呵.
shenzhenhr + 10000 + 10000 很给力!支持晓羽、初学者、套牢开帖.

总评分: 积分 + 10220  顶牛币 + 10221   查看全部评分

1万

主题

44

听众

503万

积分

管理员

Rank: 10Rank: 10Rank: 10

UID
2
好友
142
精华
3
顶牛币
1895960
在线时间
4977 小时
注册时间
2012-9-1

常胜勋章 周荐股冠军

发表于 2012-10-1 10:10 |显示全部楼层
支持晓羽、套牢、初学者。有你们的公式,顶牛们会更好选到好股。
顶牛论坛每日荐股比赛http://www.dingniu5.com/forum.php?mod=viewthread&tid=1129&fromuid=2
回复

使用道具 举报

89

主题

2

听众

198万

积分

顶牛元老

Rank: 8Rank: 8

UID
55
好友
14
精华
0
顶牛币
1560828
在线时间
105 小时
注册时间
2012-9-5

地主会成员 热心会员

发表于 2012-10-1 11:36 |显示全部楼层
支持,,,,,,,,,,,,火,论坛肯定会火
回复

使用道具 举报

1

主题

2

听众

14万

积分

顶牛元老

Rank: 8Rank: 8

UID
100
好友
8
精华
0
顶牛币
120177
在线时间
41 小时
注册时间
2012-9-6
发表于 2012-10-2 07:34 |显示全部楼层
支持,一向喜欢看看技术指标的
回复

使用道具 举报

150

主题

1

听众

18万

积分

禁止发言

UID
91
好友
15
精华
6
顶牛币
162395
在线时间
180 小时
注册时间
2012-9-6

地主会成员 论坛元老

发表于 2012-10-2 17:04 |显示全部楼层
大家节日愉快!!!
回复

使用道具 举报

0

主题

2

听众

2万

积分

顶牛元老

Rank: 8Rank: 8

UID
159
好友
0
精华
0
顶牛币
177
在线时间
9 小时
注册时间
2012-9-10
发表于 2012-10-3 16:31 |显示全部楼层
xx//////////////
回复

使用道具 举报

150

主题

1

听众

18万

积分

禁止发言

UID
91
好友
15
精华
6
顶牛币
162395
在线时间
180 小时
注册时间
2012-9-6

地主会成员 论坛元老

发表于 2012-10-4 11:45 |显示全部楼层
谢谢请把大智慧改成通达信的:

KD

MA5:=ma(c,5);
DRAWGBKLAST(MA5>=ref(MA5,1),STRIP(RGB(0,150,0),RGB(150,0,0),1));
DRAWGBKLAST(MA5<=ref(MA5,1),STRIP(RGB(150,0,0),RGB(0,150,0),1));


LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
AH:=HHV(RSI1,8);
AL:=LLV(RSI1,8);
STO1:=IF(AL=AH,0,100*(RSI1-AL)/(AH-AL));
SK:EMA(STO1,5),linethick0;
SD:EMA(SK,3),linethick0;
A:80;
B:20;
xg:sd<25 and cross(sk,sd),linethick0;
STICKLINE(xg,0,100,1,0) ;
STICKLINE(sk>sd,ref(sk,1),sk,8,0) ,COLOR000466;
STICKLINE(sk>sd,ref(sk,1),sk,7,0) ,COLOR000499;
STICKLINE(sk>sd,ref(sk,1),sk,5,0) ,COLOR0003bb;
STICKLINE(sk>sd,ref(sk,1),sk,3,0) ,COLOR0002dd;
STICKLINE(sk>sd,ref(sk,1),sk,1,0) ,COLOR0001ff;

STICKLINE(sk<sd ,ref(sk,1),sk,8,0 ),COLOR006600;
STICKLINE(sk<sd ,ref(sk,1),sk,7,0 ),COLOR009900;
STICKLINE(sk<sd,ref(sk,1),sk,5,0 ),COLOR00BB00;
STICKLINE(sk<sd,ref(sk,1),sk,3,0 ),COLOR00DD00;
STICKLINE(sk<sd,ref(sk,1),sk,1,0 ),COLOR00FF00;
回复

使用道具 举报

4

主题

4

听众

3万

积分

顶牛元老

Rank: 8Rank: 8

UID
328
好友
16
精华
0
顶牛币
34856
在线时间
99 小时
注册时间
2012-10-4

地主会成员 论坛元老

发表于 2012-10-4 17:08 |显示全部楼层
(通达信)求老师将下面公式中“庄拉线”出现时,即图中的黄线出现时,不是白线或红线出现, 做个预警公式或者选股公式,谢谢
源码:VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=REF(LLV(CLOSE,480),1);
VAR6:=REF(HHV(CLOSE,480),1);
VAR7:=100*(CLOSE-VAR5)/(VAR6-VAR5);
VAR8:=(CLOSE-LLV(CLOSE,981))/(HHV(CLOSE,981)-LLV(CLOSE,981))*100;
VAR9:=(CLOSE-LLV(CLOSE,393))/(HHV(CLOSE,393)-LLV(CLOSE,393))*100;
VARA:=(CLOSE-LLV(LOW,981))/(HHV(HIGH,981)-LLV(LOW,981))*100;
VARB:=(CLOSE-LLV(LOW,393))/(HHV(HIGH,393)-LLV(LOW,393))*100;
VARC:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5)/4;
VARD:=IF(DATE<1031231,IF(VARC>23.16,VARC,0),0);
VARE:=VARC<1;
VARF:=VARD;
VAR10:=VAR4<0 AND VAR7<0;
VAR11:=1;
VAR12:=(HIGH+LOW+CLOSE*2)/4*VAR11;
VAR13:=EMA(VAR12,21);
VAR14:=STD(VAR12,21);
VAR15:=((VAR12-VAR13)/VAR14*100+200)/4*VAR11;
VAR16:=(EMA(VAR15,89)-25)*1.56*VAR11;
VAR17:=EMA(VAR16,5)*1.22*VAR11;
VAR18:=EMA(VAR17,3)*VAR11;
VAR19:=3*VAR17-2*VAR18*VAR11;
VAR1A:=IF(CROSS(VAR19,VAR17) AND CROSS(VAR19,VAR18) AND CROSS(VAR17,VAR18),1,0); VAR1B:=IF(CROSS(VAR17,VAR19) AND CROSS(VAR18,VAR19) AND CROSS(VAR18,VAR17),1,0);
买点: IF(FILTER(VAR8=0 AND VARE AND VAR10 AND VAR1A,5)=1,10,0), COLORRED;
卖点: IF(FILTER(VAR8=100 AND VARF AND VAR1B,5)=1,10,0), COLORGREEN;
VAR1C:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),13)/4;
VAR1D:=EMA(CLOSE,2)-EMA(CLOSE,89);
VAR1E:=EMA(VAR1D,30);
VAR1F:=2*(VAR1D-VAR1E)*10;
VAR20:=POW(VAR1F,3)*0.1+POW(VAR1F,2);
VAR21:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VAR22:=EMA(VAR21*0.97,3);
VAR23:=(HIGH+LOW+CLOSE)/3;
VAR24:=(VAR23-MA(VAR23,14))/(0.015*AVEDEV(VAR23,14));
VAR25:=IF(YEAR<2008 AND VAR1F>0.015,VAR20,0)/45;
庄拉线: VAR25,COLORYELLOW ;
VAR26:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR27:=EMA(VAR26,100);
VAR28:=2*(VAR26-VAR27);
VAR29:=POW(VAR28,3)*0.1+POW(VAR28,1);
VAR2A:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VAR2B:=EMA(VAR2A*0.97,3);
VAR2C:=(HIGH+LOW+CLOSE)/3;
VAR2D:=(VAR2C-MA(VAR2C,14))/(0.015*AVEDEV(VAR2C,14));
黑马线: IF( VAR28>0.1,VAR29,0)*5, COLORRED;
量价线: (CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100, COLORWHITE;
VAR2E:=IF(FILTER(量价线>0 AND 量价线<3,5)=1,12,0);
涨幅前兆: IF(FILTER(庄拉线>0 AND 庄拉线<0.5 AND VAR2E AND VAR1C<3,10)=1,10,0), COLORWHITE;
选股利器: IF(FILTER(VAR2E>0 AND VAR1C<2 AND 庄拉线>0 AND 庄拉线<1 AND 黑马线>0 AND 黑马线<1.5 AND VAR2E>0,5)=1,10,0),COLORFFFFFF; DRAWICON(买点>0,10,1);
DRAWICON(卖点>0,10,2);
DRAWICON(涨幅前兆>0,10,1);
DRAWICON(选股利器>0,10,1);
回复

使用道具 举报

23

主题

10

听众

5万

积分

版主

Rank: 7Rank: 7Rank: 7

UID
26
好友
16
精华
6
顶牛币
25550
在线时间
143 小时
注册时间
2012-9-4
发表于 2012-10-4 20:58 |显示全部楼层
大连小飞象 发表于 2012-10-4 11:45
谢谢请把大智慧改成通达信的:

KD

双节愉快,呵呵!你的问题属于函数转换,已经超出本帖范围。你源码的第二句和第三句是背景填充去掉就可以了。
MA5:=MA(C,5);
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
AH:=HHV(RSI1,8);
AL:=LLV(RSI1,8);
STO1:=IF(AL=AH,0,100*(RSI1-AL)/(AH-AL));
SK:EMA(STO1,5),LINETHICK0;
SD:EMA(SK,3),LINETHICK0;
A:80,COLORLIGRAY;
B:20,COLORBLUE;
XG:SD<25 AND CROSS(SK,SD),LINETHICK0;
STICKLINE(XG,0,100,1,0),COLORMAGENTA;
STICKLINE(SK>SD,REF(SK,1),SK,8,0) ,COLOR000466;
STICKLINE(SK>SD,REF(SK,1),SK,7,0) ,COLOR000499;
STICKLINE(SK>SD,REF(SK,1),SK,5,0) ,COLOR0003BB;
STICKLINE(SK>SD,REF(SK,1),SK,3,0) ,COLOR0002DD;
STICKLINE(SK>SD,REF(SK,1),SK,1,0) ,COLOR0001FF;

STICKLINE(SK<SD ,REF(SK,1),SK,8,0 ),COLOR006600;
STICKLINE(SK<SD ,REF(SK,1),SK,7,0 ),COLOR009900;
STICKLINE(SK<SD,REF(SK,1),SK,5,0 ),COLOR00BB00;
STICKLINE(SK<SD,REF(SK,1),SK,3,0 ),COLOR00DD00;
STICKLINE(SK<SD,REF(SK,1),SK,1,0 ),COLOR00FF00;
已有 1 人评分积分 收起 理由
大连小飞象 + 100 赞一个!

总评分: 积分 + 100   查看全部评分

回复

使用道具 举报

23

主题

10

听众

5万

积分

版主

Rank: 7Rank: 7Rank: 7

UID
26
好友
16
精华
6
顶牛币
25550
在线时间
143 小时
注册时间
2012-9-4
发表于 2012-10-4 21:04 |显示全部楼层
小毛驴007 发表于 2012-10-4 17:08
(通达信)求老师将下面公式中“庄拉线”出现时,即图中的黄线出现时,不是白线或红线出现, 做个预警公式 ...

你要求的选点已过期了,你只能看到2008年以前的信号(这公式里已经设置了)
以下是选股公式:
VAR1D:=EMA(CLOSE,2)-EMA(CLOSE,89);
VAR1E:=EMA(VAR1D,30);
VAR1F:=2*(VAR1D-VAR1E)*10;
庄拉线:CROSS(YEAR<2008 AND VAR1F>0.015,0.5);
===================
如果你想使用的话你可自己改下设置的年份

点评

小毛驴007  老师:公式中有买卖点,为什么在副图中看不到买卖点数值及信号啊?  发表于 2012-10-5 12:41
小毛驴007  O(∩_∩)O谢谢  发表于 2012-10-5 12:29
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册


回顶部