请选择 进入手机版 | 继续访问电脑版

顶牛论坛

 找回密码
 立即注册
搜索

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

量价招式擒获飞天妖股

强势黑马起爆点指标主力吸筹完毕启动四色柱很牛的副图指标黄金柱  好用的成交量指标
机构买入看盘牛股启动指标公式百万股神擒牛指标公式短线底部抄底和高位逃顶指标
绝密量能买点主力暴力拉升指标公式洞察主力游资大户散户资金王子操盘线指标公式
集合竞价抓板指标公式通达信龙虎榜通达信主力控盘系数通达信六区DK指标
抓起爆点超精准选股公式通达信控盘程度选股公式源码RSI突破下降趋势线股票活跃度指标公式
楼主: 晓羽

[通达信] 【公式改写成选股公式】 老帖新开

  [复制链接]

6

主题

2

听众

5万

积分

顶牛元老

Rank: 8Rank: 8

UID
403
好友
6
精华
0
顶牛币
20166
在线时间
71 小时
注册时间
2012-10-15
发表于 2012-11-1 16:53 |显示全部楼层
分享到:
回复

使用道具 举报

6

主题

2

听众

5万

积分

顶牛元老

Rank: 8Rank: 8

UID
403
好友
6
精华
0
顶牛币
20166
在线时间
71 小时
注册时间
2012-10-15
发表于 2012-11-1 16:58 |显示全部楼层
回复

使用道具 举报

23

主题

10

听众

5万

积分

版主

Rank: 7Rank: 7Rank: 7

UID
26
好友
16
精华
6
顶牛币
25550
在线时间
143 小时
注册时间
2012-9-4
发表于 2012-11-1 17:30 |显示全部楼层
lhdyhm 发表于 2012-11-1 15:46
老师装不上【当前公式 : 涨跌动力选股 (指标画线公式)  
错误句 :
上涨动能:=SMA(VAR2,8,1)+0.2

抱歉,复制粘贴时漏了分号
VAR2:=(CLOSE-LLV(LOW,14))/(HHV(HIGH,11)-LLV(LOW,11))*100;
上涨动能:=SMA(VAR2,8,1)+0.2;
XG:COUNT(C<REF(C,1) AND C<O,3)=3 AND COUNT(上涨动能>REF(上涨动能,1),3)=3;

点评

lhdyhm  谢谢老师;呵呵呵呵装上了  详情 回复 发表于 2012-11-1 18:01
回复

使用道具 举报

6

主题

2

听众

5万

积分

顶牛元老

Rank: 8Rank: 8

UID
403
好友
6
精华
0
顶牛币
20166
在线时间
71 小时
注册时间
2012-10-15
发表于 2012-11-1 18:01 |显示全部楼层
晓羽 发表于 2012-11-1 17:30
抱歉,复制粘贴时漏了分号
VAR2:=(CLOSE-LLV(LOW,14))/(HHV(HIGH,11)-LLV(LOW,11))*100;
上涨动能:=SMA(V ...

谢谢老师;呵呵呵呵装上了
回复

使用道具 举报

6

主题

2

听众

5万

积分

顶牛元老

Rank: 8Rank: 8

UID
403
好友
6
精华
0
顶牛币
20166
在线时间
71 小时
注册时间
2012-10-15
发表于 2012-11-3 09:16 |显示全部楼层
本帖最后由 晓羽 于 2012-11-3 09:36 编辑

老师你好;请你在给做个选股公式吧.【条件是出现建仓买点=5时选股】源码是;LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳买入:=(AV + NEWVOL);
买入选股:IF(CROSS(最佳买入,0),4,0),STICK,COLOR00FFFF,LINETHICK2;
VARA1:=SMA(买入选股,3,1);
VARA2:=SMA(VARA1,3,1),COLOR0000FF;
VARA3:=SMA(VARA2,3,1),COLOR00FFFF;
建仓买点:IF(CROSS(VARA2,VARA3) AND (VARA2<40),5,0* 10000),COLOR0000FF,LINETHICK1;
STICKLINE(建仓买点,0,1.5,6,0),COLORFF80FF;
STICKLINE(建仓买点,0.5,2.8,2,0),COLOR3000FF;
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 50);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
最佳买入时机: IF(CROSS(J,3),1,0),STICK,COLORFFFF00;
STICKLINE(最佳买入时机,0,1,3,0),COLOR009999;
STICKLINE(最佳买入时机,0,1,2,0),COLOR00DDDD;
STICKLINE(最佳买入时机,0,1,1,0),COLOR00FFFF;
机构建仓: IF(最佳买入<5,-0.5,0),STICK,COLOR00FF00,LINETHICK1;
机构建仓日:STICKLINE(机构建仓,0,-1,4,1),COLOR00FF00,LINETHICK5;
趋势:3*SMA((CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK2,COLORFF99FF,NODRAW;
备钱: IF(趋势<=20,-0.8,0),COLORD0D0D0,STICK,LINETHICK3;
快买: IF(趋势<=10,1,0),COLORFF38FF,STICK,LINETHICK3;
BIAS1:=(C-MA(C,6))/MA(C,6)*100,COLORFFDDCC;
BIAS2:(C-MA(C,13))/MA(C,13)*100,COLORFFFFFF,LINETHICK1;
BIAS3:=(C-MA(C,26))/MA(C,26)*100,COLORFFFFFF,LINETHICK1;
乖离:(BIAS1+2*BIAS2+3*BIAS3)/6,COLOR00FFFF;
乖离超限:MA(乖离,3),COLORFF80FF;
STICKLINE(CROSS(乖离,乖离超限)  AND 乖离超限<-9,-4,0,1,1),COLORFFFFFF;
STICKLINE(CROSS(乖离超限,乖离)  AND 乖离>10,6,0,3,0),COLORFF88FF;
DRAWBAND(MA(乖离,1),RGB(240,120,40),MA(乖离超限,1),RGB(256,200,20));
警跌:IF(BIAS2<REF(BIAS2,1),BIAS2,DRAWNULL),COLORFF6128,LINETHICK3;
回升:IF(BIAS2>REF(BIAS2,1),BIAS2,DRAWNULL),COLOR00FFFF,LINETHICK3;
R:SMA(MAX(CLOSE- REF(C,1),0),6,1)/SMA(ABS(CLOSE- REF(C,1)),6,1)*100,COLORFFCCFF,NODRAW;
R2:SMA(MAX(CLOSE- REF(C,1),0),13,1)/SMA(ABS(CLOSE- REF(C,1)),13,1
)*100,COLOR00CCFF,NODRAW;
STICKLINE(CROSS(R2,R)  AND R2>78,2,0,3,-1),COLOR30FFFF;
CC:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD:=L<MA(C,5)*0.921;
EE:=V<MA(V,5)*1.5;
老鼠仓:=(L<(AMOUNT/V)*0.9) AND CC AND DD AND EE,LINETHICK0,COLOR0099FF;
DRAWTEXT(老鼠仓,-5,'老鼠仓'),COLORFFFFFF;
选底:TROUGHBARS(3,15,1)<4,NODRAW;
DRAWTEXT(FILTER(选底=1,3),-2,'底部'),COLOR00FF00;
头部:=IF((PEAKBARS(3,15,1)<10)=1,2,0);
快逃:=IF(头部>REF(头部,1),H,0),COLORWHITE,NODRAW;
DRAWTEXT(快逃=H,6,'头部'),COLOR0000FF,LINETHICK1;
STICKLINE(CROSS(乖离,BIAS1)  AND BIAS2>15,乖离,0,1,0),COLOR3300FF;
DRAWICON(CROSS(乖离,BIAS1*0.382),-1,1),COLORGREEN;

点评

lhdyhm  谢谢知道了  详情 回复 发表于 2012-11-3 09:45
晓羽  我重编辑了一下,以后再发源码帖时,在禁用表情一栏打上勾就可以了。  发表于 2012-11-3 09:39
回复

使用道具 举报

6

主题

2

听众

5万

积分

顶牛元老

Rank: 8Rank: 8

UID
403
好友
6
精华
0
顶牛币
20166
在线时间
71 小时
注册时间
2012-10-15
发表于 2012-11-3 09:45 |显示全部楼层
lhdyhm 发表于 2012-11-3 09:16
老师你好;请你在给做个选股公式吧.【条件是出现建仓买点=5时选股】源码是;LC:=REF(CLOSE,1);
RSI5:=((SMA ...

谢谢知道了
回复

使用道具 举报

23

主题

10

听众

5万

积分

版主

Rank: 7Rank: 7Rank: 7

UID
26
好友
16
精华
6
顶牛币
25550
在线时间
143 小时
注册时间
2012-9-4
发表于 2012-11-3 09:48 |显示全部楼层
lhdyhm 发表于 2012-11-3 09:16
老师你好;请你在给做个选股公式吧.【条件是出现建仓买点=5时选股】源码是;LC:=REF(CLOSE,1);
RSI5:=((SMA ...

LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳买入:=(AV + NEWVOL);
买入选股:=IF(CROSS(最佳买入,0),4,0);
VARA1:=SMA(买入选股,3,1);
VARA2:=SMA(VARA1,3,1);
VARA3:=SMA(VARA2,3,1);
建仓买点:CROSS(VARA2,VARA3) AND (VARA2<40);

点评

lhdyhm  老师谢谢你的帮助  详情 回复 发表于 2012-11-3 10:33
回复

使用道具 举报

6

主题

2

听众

5万

积分

顶牛元老

Rank: 8Rank: 8

UID
403
好友
6
精华
0
顶牛币
20166
在线时间
71 小时
注册时间
2012-10-15
发表于 2012-11-3 10:33 |显示全部楼层
晓羽 发表于 2012-11-3 09:48
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:= ...

老师谢谢你的帮助
已有 1 人评分积分 顶牛币 收起 理由
晓羽 + 100 + 100 欢迎你及你的朋友们常来交流!.

总评分: 积分 + 100  顶牛币 + 100   查看全部评分

回复

使用道具 举报

3360

主题

8

听众

5万

积分

顶牛元老

Rank: 8Rank: 8

UID
35
好友
3
精华
2
顶牛币
32032
在线时间
110 小时
注册时间
2012-9-4
发表于 2012-11-3 11:25 |显示全部楼层
久仰你的大名。楼主。
已有 1 人评分积分 顶牛币 收起 理由
晓羽 + 100 + 100 你客气了,欢迎常来交流!

总评分: 积分 + 100  顶牛币 + 100   查看全部评分

回复

使用道具 举报

2

主题

3

听众

5581

积分

顶牛元老

Rank: 8Rank: 8

UID
358
好友
0
精华
0
顶牛币
4128
在线时间
100 小时
注册时间
2012-10-9
发表于 2012-11-4 21:44 |显示全部楼层
月周日裸K同图  主图
STICKLINE(1=1,H,L,9,0)COLOR000000;
MC:=C#MONTH;MO:=O#MONTH;MH:=H#MONTH;ML:=L#MONTH;
ZC:=C#WEEK;ZO:=O#WEEK;ZH:=H#WEEK;ZL:=L#WEEK;
STICKLINE(MC>=MO,MO,MC,3,-1),COLOR73599D;
STICKLINE(MC<MO,MO,MC,3,-1),COLOR8A8E31;
STICKLINE(ZC>=ZO,ZO,ZC,4,0)COLOR00009C;
STICKLINE(ZC<ZO,ZO,ZC,4,0),COLOR9F3333;
KJY:=H#MONTH-L#MONTH;HY5:=H#MONTH-KJY*0.500;
HY1:=IF(CONST(C)>=H#MONTH-KJY*0.500,H#MONTH-KJY*0.382,H#MONTH-KJY*0.618),CIRCLEDOT;
HY2:=IF(CONST(C)>=H#MONTH-KJY*0.500,H#MONTH-KJY*0.191,H#MONTH-KJY*0.809),CIRCLEDOT;
HY3:=IF(CONST(C)>=H#MONTH-KJY*0.500,H#MONTH-KJY*0.25,H#MONTH-KJY*0.75),CIRCLEDOT;
STICKLINE(C , HY1,HY1,3,-1),COLORRED;
STICKLINE(C , HY2,HY2,3,-1),COLORFFFF00;
STICKLINE(C, HY5,HY5,3,1),COLORFF00FF;
STICKLINE(C , HY3,HY3,3,-1),COLORRED;
{STICKLINE(C AND <=55, HY5,HY5,3,1),COLORFF00FF;
STICKLINE(1,ZH,ZO,1/10,0),COLOR00599D;
STICKLINE(1,ZC,ZL,1/10,0),COLOR008E31;};
DRAWKLINE(H,O,L,C);

请  老师 帮忙  做出 股价 处在 红块区  选股公式
谢谢!
红块区.jpg
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册


回顶部