请选择 进入手机版 | 继续访问电脑版

顶牛论坛

 找回密码
 立即注册
搜索

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

量价招式擒获飞天妖股

强势黑马起爆点指标主力吸筹完毕启动四色柱很牛的副图指标黄金柱  好用的成交量指标
机构买入看盘牛股启动指标公式百万股神擒牛指标公式短线底部抄底和高位逃顶指标
绝密量能买点主力暴力拉升指标公式洞察主力游资大户散户资金王子操盘线指标公式
集合竞价抓板指标公式通达信龙虎榜通达信主力控盘系数通达信六区DK指标
抓起爆点超精准选股公式通达信控盘程度选股公式源码RSI突破下降趋势线股票活跃度指标公式
查看: 29|回复: 0

[通达信] 通达信趋势指标公式副图源码

[复制链接]

1629

主题

0

听众

1万

积分

版主

Rank: 7Rank: 7Rank: 7

UID
11
好友
2
精华
0
顶牛币
4118
在线时间
53 小时
注册时间
2012-9-3
发表于 2019-5-2 07:41 |显示全部楼层
分享到:
通达信公式趋势指标公式副图源码

{KKDD中线}
LOWV1:=EMA(LLV(LOW,34),3);
HIGHV1:=EMA(HHV(HIGH,34),3);
RSV1:=EMA((CLOSE-LOWV1)/(HIGHV1-LOWV1)*100,3);
长线1:SMA(RSV1,8,1),COLORMAGENTA,LINETHICK1,NODRAW;
长线2:SMA(长线1,6,1),COLORGRAY,LINETHICK1,NODRAW;
DRAWBAND(长线1,RGB(200,0,200),长线2,RGB(100,100,100));

50,COLORRED,LINETHICK2;
105,COLORFF7F00,DOTLINE;

{强势有效}
DIFF1:=EMA(CLOSE,12)-EMA(CLOSE,26);
短线买点:=CROSS(((DIFF1-EMA(DIFF1,9))*10-REF((DIFF1-EMA(DIFF1,9))*10,1)),1) AND (DIFF1-EMA(DIFF1,9))*10>1;
STICKLINE(短线买点>0,0,45,1.3,0),COLOR008888;
STICKLINE(短线买点>0,0,45,0.9,0),COLOR00AAAA;
STICKLINE(短线买点>0,0,45,0.6,0),COLOR00DDDD;
STICKLINE(短线买点>0,0,45,0.2,0),COLOR00FFFF;
DRAWTEXT(短线买点>0,43,'☆预警'),COLOR00FFFF,LINETHICK1;

0,COLORWHITE,LINETHICK1;

{KDJ短线}
RSV:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
短线2:SMA(RSV,3,1),COLORWHITE,LINETHICK2;
D:=SMA(短线2,3,1),COLOR00FFFF,LINETHICK2;
{J线没未来}
短线1:3*短线2-2*D,COLOR00FFFF,LINETHICK2;
IF(短线1<REF(短线1,1),短线1,DRAWNULL),COLORGREEN,LINETHICK2;
IF(短线1>REF(短线1,1),短线1,DRAWNULL),COLORRED,LINETHICK2;

{KDJ红绿相交}
DRAWICON(CROSS(短线1,D) AND CROSS(短线1,短线2),0,25);
DRAWICON(CROSS(D,短线1) AND CROSS(短线2,短线1),110,27);
{KKDD红绿箭头}
DRAWICON(CROSS(长线1,长线2),长线2,1);
DRAWICON(CROSS(长线2,长线1),长线2,2);
{横盘启动}
LOWV:=LLV(LOW,15); {15天内的最低价}
HIGHV:=HHV(HIGH,15); {15天内的最高价}
HIGHVV:=HHV(HIGH,40); {40天内的最高价}
V0:=V; {当天的成交量}
V1:=REF(V,1); {一天前的成交量}
V2:=REF(V,2); {两天前的成交量}
V3:=REF(V,3); {三天前的成交量}
HV22:=HHV(V,35); {35天内的最大成交量}
D0U:=C>O; {今天是阳线}
D1U:=REF(C,1)>=REF(C,2); {昨天是阳线}

横盘:=((HIGHV-LOWV)/HIGHV)<0.15; {半个月内价格波动小于15%}
放量1:=V0>=(1.8*((V1+V2+V3)/3)); {今天量是前三天均量的1.8倍}
放量2:=V0<=(3.8*V1); { 今天的量在昨天量的四倍范围内}
今天阳线:=D0U; {今天是阳线}
昨天阳线:=D1U; {昨天是阳线}
今天中阳:=(C-REF(C,1))/REF(C,1)>=0.018; {今天涨幅大于1.8%}
开盘非最高价:=C<=HIGHVV; {收盘非40天内最高价}
收盘非最高价:=O<=HIGHVV; {开盘非40天内最高价}
非最大成交量:=V0<HV22; {非一个月内最高成交量}
启动突破:=横盘 AND 放量1 AND 放量2 AND 今天阳线 AND 昨天阳线 AND 今天中阳 AND 开盘非最高价 AND 收盘非最高价 AND
非最大成交量;
IF(启动突破>0,48,0),COLORWHITE,LINETHICK2;
DRAWTEXT(启动突破>0,45,'启动'),COLORFFFFFF;

DRAWTEXT(ISLASTBAR,55,'↓弱'),COLORGREEN;
DRAWTEXT(ISLASTBAR,5,'准备'),COLORCYAN;

20,COLOR4080FF,DOTLINE;
DRAWTEXT(ISLASTBAR,25,'关注'),COLOR4080FF;
40,COLOR00FFFF,DOTLINE;
60,COLORLIRED,DOTLINE;
DRAWTEXT(ISLASTBAR,65,'↑强'),COLORRED;
85,COLORA943FF,DOTLINE;
DRAWTEXT(ISLASTBAR,90,'强势'),COLORRED;

坐标线位置:
0.00;20.00;40.00;50.00;60.00;85.00;105.00
傲游截图20190502070242.png



您需要登录后才可以回帖 登录 | 立即注册


回顶部